Loading Issues in Science and ELA

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Feb 04, 2026 - 16:43 EST

Update

We are continuing to monitor for any further issues.
Posted Feb 04, 2026 - 15:03 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2026 - 15:03 EST

Investigating

We are aware of loading issues within our Science and ELA programs. This is due to an issue with one of our upstream providers.

We are monitoring the status of this issue and will notify you once it has been resolved.

We greatly appreciate your patience!
Posted Feb 04, 2026 - 13:49 EST
This incident affected: Amplify ELA and Amplify Science.