Phone Support Issues
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 13:08 EDT
Investigating
Our phone service provider has an issue impacting audio quality on inbound/outbound calls. As a result, if you place a call to our Customer Support team, you or the agent on the other end may experience a disruption in service.

In the meantime, we advise that you reach out to our Customer Support teams via email (help@amplify.com) or the chat platform embedded within each product.

We apologize for this inconvenience and hope to see resolution on the part of our phone service provider soon!
Posted Apr 22, 2024 - 12:39 EDT
This incident affected: Customer Support.