A fix has been implemented and we are monitoring the results.
Posted Apr 28, 2025 - 16:06 EDT
Update
UPDATE: Teachers are unable to view recent student submissions (last 4 hours~) due to an issue with an upstream provider. Student submissions are being saved, and there is no data loss.
Our Engineering team is investigating a fix for this issue now.
Posted Apr 28, 2025 - 13:54 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 28, 2025 - 13:19 EDT
Investigating
We are aware of and investigating reports of student work is not populating Classwork for some users. Our Engineering team is currently working on identifying the root cause of this issue so that they may resolve it as quickly as possible.
We appreciate your patience as we work towards resolving this issue!
Posted Apr 28, 2025 - 12:10 EDT
This incident affected: Amplify ELA and Amplify Science.