Polypad and Fluency Loading Issues
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Oct 24, 2024 - 19:46 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 23, 2024 - 15:14 EDT
Investigating
We are aware of and investigating an issue with long load times and 500 errors for users of the Polypad and Fluency applications. Our engineering team is working diligently to identify the root cause of and resolve these issues.

We hope to resolve these issues quickly and apologize for any disruption this may be causing. We will provide more updates here as they come.

Thank you!
Posted Oct 23, 2024 - 12:56 EDT
This incident affected: Amplify Math, Desmos Classroom, and Desmos Classroom.