Accessibility Issues

Incident Report for Amplify

Resolved

Systems have been healthy and operational with no recurrences since ~2:30pm ET yesterday. We are setting this issue to Resolved.

Thank you again for your patience!
Posted Oct 29, 2025 - 08:35 EDT

Monitoring

A fix has been deployed. Systems are back to operational now. We will continue to monitor and will update this page in the event of recurrence.
Posted Oct 28, 2025 - 14:43 EDT

Investigating

We are aware of and investigating slow loading times and general accessibility issues across multiple Amplify products right now. Some users may also be experiencing a 502 Bad Gateway error when attempting to access learning.amplify.com.

Our Engineering team is working diligently to identify the root cause of and implement a fix for this issue as we speak. We will update this page once we have more information.

Thank you so much for your patience!
Posted Oct 28, 2025 - 14:31 EDT
This incident affected: Amplify CKLA, Amplify ELA, Boost Reading, Amplify Science, Amplify Math, mCLASS Assessment, and mCLASS Intervention.