Science and ELA - Intermittent Activity Disruption

Incident Report for Amplify

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2026 - 11:58 EDT

Investigating

We are aware of and investigating an issue affecting users' ability to access some questions in or navigate through activities within our Curriculum products. Our Engineering team is working diligently to identify the root cause of and identify a fix for this issue.

We will provide updates on this page once we have more information.

We appreciate your patience and we working towards resolving this issue as quickly as possible. Thank you so much!
Posted Mar 10, 2026 - 10:54 EDT
This incident affects: Amplify ELA and Amplify Science.