Amplify Products Currently Experiencing Service Disruption
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Sep 25, 2023 - 17:19 EDT
Monitoring
We are seeing recovery across all product lines right now. We are still investigating the root cause of this issue and monitoring the status of this service recovery.
Posted Sep 25, 2023 - 11:51 EDT
Investigating
We are aware of service disruptions affecting all Amplify products right now. We are currently investigating the root cause of this issue and working diligently to resolve it.

We greatly appreciate your patience and apologize for the disruption this may be causing in your classroom!
Posted Sep 25, 2023 - 10:32 EDT
This incident affected: Amplify CKLA, Amplify ELA, Amplify Reading, Amplify Science, Amplify Math, mCLASS Assessment, mCLASS Intervention, and Customer Support.