Administrator Reports Service Issues

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 18:29 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 08, 2025 - 14:18 EDT

Investigating

We are aware of and investigating an issue where users are unable to access Administrator Reports.

Our Product Engineering team is currently working on identifying a root cause of and implementing a fix for this issue.

We will update this page as we move closer to resolving this issue.

Thank you so much for your patience!
Posted Sep 08, 2025 - 13:50 EDT
This incident affected: Amplify CKLA, Amplify ELA, Boost Reading, Amplify Science, Amplify Math, mCLASS Assessment, and mCLASS Intervention.