Support Chat Platform Loading Issues
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Apr 11, 2023 - 10:28 EDT
Investigating
The third-party platform we utilize for live chat support is currently experiencing issues preventing some of our agents from being able to open or respond to new and ongoing chats. We are monitoring updates with their platform.

In the meantime, if you would like to contact our support team, it would be best to give them a call at 800-823-1969 or send them an email to help@amplify.com.

We apologize for any disruptions this may be causing and hope this issue is resolved soon!
Posted Apr 11, 2023 - 10:18 EDT
This incident affected: Customer Support.