Login and Navigation Service Disruption

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 11:15 EST

Monitoring

From ~1:55-2:20pm ET, we experienced an issue impacting our login services. During this time, users would have experienced issues during the login process preventing them from accessing Amplify products. We have deployed a fix for this issue and users should be seeing relief now. We are continuing to monitor.
Posted Dec 01, 2025 - 14:23 EST
This incident affected: Amplify CKLA, Amplify ELA, Boost Reading, Amplify Science, Amplify Math, Desmos Classroom, Mathigon, mCLASS Assessment, mCLASS Intervention, and Desmos Classroom.