Phone Support Service Issue

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Sep 07, 2025 - 21:09 EDT

Monitoring

Our phone service provider has implemented a fix and is monitoring the results. We have made numerous successful test calls to our system from our side.
Posted Sep 05, 2025 - 18:10 EDT

Investigating

Our phone provider is currently reporting degraded performance with several of their applications. As a result, our phone support may experience intermittent connectivity issues.

We are monitoring the status page of our phone provider for updates and will relay those updates here.

In the meantime, you can contact with us via Chat by logging into your account or by Web Form (service.amplify.com/s/support).

We appreciate your patience and hope this issue is resolved soon!
Posted Sep 05, 2025 - 16:41 EDT
This incident affected: Customer Support.