Service Disruption - Math Curriculum and Differentiation in Science and ELA
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Feb 07, 2023 - 17:41 EST
Investigating
We are aware of issues with loading in, navigation of, and access to the Math Curriculum. Other curriculum platforms, such as Science and ELA, are accessible at this time, though there may be some issues using Differentiation. Our Engineering team is investigating and working on a resolution. We appreciate your patience and apologize for any disruption this may be causing!
Posted Feb 07, 2023 - 17:11 EST
This incident affected: Amplify ELA, Amplify Science, and Amplify Math.