Close Reading is Currently Unavailable
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Jun 11, 2023 - 15:16 EDT
Investigating
We are currently aware of an issue preventing users from accessing our Close Reading (or Reading 6-8) program. Our engineering team is working to identify the root cause and resolve this issue as we speak.

We do apologize for any disruption this may be causing and greatly appreciate your patience while we work on resolving this issue.
Posted Jun 11, 2023 - 15:02 EDT
This incident affected: Amplify Reading.