mCLASS Assessment - Unexpected Error Messages

Incident Report for Amplify

Resolved

We are setting this incident to Resolved. If you are still experiencing error messages in mCLASS Assessment, please contact our Support team for further assistance: https://service.amplify.com/support

Thank you so much!
Posted Feb 13, 2026 - 12:16 EST

Monitoring

Our Engineering team has released a fix for this issue. We have been able to successfully load mCLASS Assessment on previously affected user accounts. We are leaving this incident in Monitoring status for now.

If your issue persists, please contact our Support team for further assistance: https://service.amplify.com/support

Thank you again for your patience!
Posted Feb 13, 2026 - 10:59 EST

Investigating

We are aware of and investigating reports of users encountering Unexpected Error messages when attempting to access classes on the teacher-led mCLASS Assessment page.

Our Product and Engineering teams are working diligently to identify the root cause of and implement a fix for this issue.

We will update this page once we have more information.

Thank you so much for your patience!
Posted Feb 13, 2026 - 09:57 EST
This incident affected: mCLASS Assessment.