Curriculum Service Disruption

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 12:33 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 01, 2025 - 11:28 EDT

Identified

We are aware of and investigating reports of service disruption across a number of services within the Science and ELA platforms right now. Notably, teachers may be seeing errors when attempting to lock/unlock assessments in Science, and students may be seeing error messages when attempting to save their work. Our Engineering team has identified the source of these issues and is working towards finding and implementing a fix.

We appreciate your patience as we work toward resolving these issues, and we will update this page once we have more developments.

Thank you!
Posted Apr 01, 2025 - 10:54 EDT
This incident affected: Amplify ELA and Amplify Science.