Between 11:16-11:27am ET, we saw a spike in error rates that would have manifested in time outs or error messages in mCLASS applications. These errors are consistent with the root cause for issues that emerged yesterday. Those error rates have dropped and we are continuing to monitor.
If you were experiencing issues prior or are experiencing issues since this spike, please reach out to our Customer Support teams.
Thank you!
Posted Aug 21, 2025 - 12:29 EDT
Update
Our Engineering team has implemented a fix. Users experiencing these issues should be seeing relief now. We are continuing to monitor the situation.
Please reach out to our Customer Support teams if you issues persist.
Thank you again for your patience!
Posted Aug 20, 2025 - 11:56 EDT
Investigating
We are aware of and investigating reports of long loading times and time out errors for some users across multiple platforms: mCLASS, Science, ELA, Desmos Classroom.
Our Product and Engineering teams are working to identify a root cause and implement a fix for this issues right now.
We will update this messaging once there are more developments.
We appreciate your patience and hope to resolve these issues as soon as possible!
Posted Aug 20, 2025 - 11:32 EDT
This incident affected: Amplify ELA, Amplify Science, Amplify Math, Desmos Classroom, mCLASS Assessment, mCLASS Intervention, and Desmos Classroom.