mCLASS Service Performance Errors
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Jan 12, 2024 - 14:10 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 11, 2024 - 12:25 EST
Identified
Our engineers have identified the root cause of these performance issues and are taking corrective actions to mitigate them.
Posted Jan 11, 2024 - 11:14 EST
Investigating
We are investigating instances of high error rates and/or long loading times in certain mCLASS services, such as Teacher-led Assessments and Intervention. As of now, we are still trying to identify the root cause of this issue.

We understand that this may be causing disruption in the classroom and we appreciate your patience as we work diligently towards resolving this issue.

Thank you!
Posted Jan 11, 2024 - 10:47 EST
This incident affected: mCLASS Assessment and mCLASS Intervention.