mCLASS applications - Classroom Reporting, Teacher-led Assessment, Student Online Assessment (teacher and students) - saw a spike in errors in our internal databases from ~6:20-6:45pm ET.
Those errors have since subsided and we are monitoring progress.
Posted Aug 25, 2025 - 18:53 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2025 - 17:07 EDT
Update
Upon further investigation, we are seeing errors affecting multiple mCLASS applications - Classroom Reporting, Teacher-led Assessment, Student Online Assessment (teacher and students affected).
Our Product and Engineering teams are aware of the spike in these error rates and working to implement a fix for them now.
Posted Aug 25, 2025 - 14:30 EDT
Investigating
We are aware of an issue where teachers and students attempting to access the Student Online Assessment are receiving 503 error messages.
Our Product and Engineering teams are working diligently to identify the root cause of and implement a fix for this issue.
We will update this page once we have more information.
We appreciate your patience and apologize for the inconvenience!
Posted Aug 25, 2025 - 14:19 EDT
This incident affects: mCLASS Assessment and mCLASS Intervention.