mCLASS Student Assessments: Brief Service Disruption

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 09:56 EDT

Monitoring

Between 7:00-8:50pm ET, we experienced a service disruption to mCLASS Student Online Assessments. During this window, students may have received an error message preventing them from starting their online assessment.

Service has since been restored and we are continuing to monitor.

Thank you!
Posted Sep 08, 2026 - 22:25 EDT
This incident affected: mCLASS Assessment.