Live Chat Feature is Currently Inaccessible
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 11:12 EST
Investigating
The live chat feature used by customers to connect with our support team is currently inaccessible to Amplify employees. Educators are still able to open and send chats, but there are no agents on the receiving end at this point.

To ensure continuity of support, please reach out to us my phone (800-823-1969) or email (help@amplify.com) while we continue working with our live chat provider to resolve this issue.

Thank you!
Posted Feb 14, 2024 - 10:01 EST
This incident affected: Customer Support.