mCLASS Performance Issues

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 17:57 EDT

Identified

We have seen an uptick in reports of this issue and are continuing to investigate.
Posted Oct 24, 2025 - 14:07 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2025 - 13:44 EDT

Investigating

We are aware of and investigating an issue where some users are seeing error messages across multiple mCLASS applications (Intervention, Student Assessment, Teacher Assessment, Classroom Reporting). Our Product team is currently working on identifying the root cause of and implementing a fix for this issue.

We thank you for your patience and will continue providing updates here!
Posted Oct 24, 2025 - 13:13 EDT
This incident affected: mCLASS Assessment and mCLASS Intervention.