Amplify Desmos Math Access Issues

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 11:37 EDT

Monitoring

A fix has been implemented and we are monitoring the results now. Our internal testing has passed and all users should be seeing relief.

Please contact our Support Team if you are still having issues accessing Amplify Desmos Math.

Thank you!
Posted Apr 01, 2025 - 09:47 EDT

Identified

We have an identified an issue where Amplify Desmos Math users are currently unable to access this program. Our Product and Engineering teams are currently working on a fix to restore access.

We apologize for this disruption and hope to resolve this issue as quickly as possible. We will update this posting once we have more developments.

Thank you!
Posted Apr 01, 2025 - 09:41 EDT
This incident affected: Amplify Math.