Admin Reports Accessibility Issue

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 09:58 EDT

Monitoring

Admin Reports and Boost Usage functionality has returned to normal and all data is up-to-date. Our Data and Engineering teams will continue to monitor data pipelines throughout the nightly runs.
Posted Mar 19, 2025 - 20:10 EDT

Update

Admin Report services are now back up and running in production. Users should be seeing relief now!

If you are still experiencing an error when attempting to open Admin Reports, please report this issue to our Support teams via chat, email (help@amplify.com), or phone (800-823-1969).

Please note: While the Admin Report services have been restored, some users may experience a delay in data. We are working on restoring this data and will continue updating this page until the issue has been fully resolved.

Thank you again for your patience!
Posted Mar 19, 2025 - 16:41 EDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 19, 2025 - 13:36 EDT

Identified

Some users may be unable to access Admin Reports and Boost Usage Dashboards due to a performance issue from our third party data warehouse provider. Per communication from our data warehouse provider: "We've identified the source of the issue, and we're developing and implementing a fix to restore service."

We understand this frustration a disruption like this can cause, and we greatly appreciate your patience while our data warehouse provider works towards resolving these performance issues.
Posted Mar 19, 2025 - 12:39 EDT
This incident affected: Amplify CKLA, Amplify ELA, Amplify Reading, Amplify Science, and Amplify Math.