Assign Button Functionality and Stream Latency

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Nov 02, 2025 - 21:18 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 31, 2025 - 11:39 EDT

Investigating

We are aware of and investigating an issue where the Assign button and Single Session Codes are not functioning properly for some users. This issue is also impacting the Stream section on Educator Home where we are seeing long load times.

Our Engineering team is currently working to identify the root cause of and implement a fix for these issues.

In the meantime, we recommend using the print material option found at the bottom of each lesson. The Unit Overview also provides a PDF of the entire chapter.

Please continue monitoring this page for more updates about this issue.

Thank you for your patience!
Posted Oct 31, 2025 - 10:50 EDT
This incident affected: Amplify CKLA, Amplify Math, Desmos Classroom, and Desmos Classroom.