Boost Reading Accessibility Issue

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 12:17 EDT

Investigating

We are aware of and investigating an issue where Boost Reading users are currently unable to access the program. Our Product team is working diligently to identify the root cause of and provide a resolution for this issue.

We apologize for this disruption and will post updates on this page as we work towards resolution!
Posted Mar 21, 2025 - 11:43 EDT
This incident affected: Amplify Reading.