Scheduled Maintenance Window

Incident Report for Amplify

Resolved

Yesterday evening’s scheduled maintenance was successful.
Posted Apr 03, 2026 - 08:22 EDT

Monitoring

We will be undergoing scheduled maintenance on Thursday 4/2 beginning at 10pm EST. The duration of this maintenance is not expected to last long. Users will experience system downtime during this window.
Posted Apr 02, 2026 - 18:57 EDT
This incident affected: Amplify CKLA, Amplify ELA, Boost Reading, Amplify Science, Amplify Math, Desmos Classroom, Mathigon, mCLASS Assessment, mCLASS Intervention, Amplify.com, Customer Support, Desmos Classroom, and Math ANEX.