eReader: Slow Load Times
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Feb 15, 2024 - 12:07 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2024 - 13:16 EST
Investigating
At this time, we are still receiving reports of slow loading when teachers or students attempt to load the eReader. This behavior is replicable but also intermittent, meaning refreshing the page may resolve this issue. Our Engineering team is aware of these reports and working diligently towards a resolution.

We appreciate your patience while we continue investigating this issue!
Posted Feb 13, 2024 - 12:30 EST
This incident affected: Amplify ELA and Amplify Science.