6-8 Science and ELA: Student Activity Disruption

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Jan 13, 2026 - 21:49 EST

Monitoring

Our Engineering team has deployed a fix and users should be seeing full recovery now.
Posted Jan 13, 2026 - 11:28 EST

Investigating

We are aware of and investigating an issue impacting our 6-8 ELA and Science programs. Students are encountering issues when selecting multiple-choice answers, dragging and dropping answers, etc.

Our Engineering team is working to identify the root cause and implement a fix for this issue.

Thank you for your patience!
Posted Jan 13, 2026 - 11:13 EST
This incident affected: Amplify ELA and Amplify Science.