mCLASS Assessment Loading Issue
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Jan 10, 2024 - 11:59 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 04, 2024 - 17:36 EST
Investigating
We are aware of and investigating an issue where some teachers are unable to load assessments within the mCLASS Teacher-Led Assessment page. We are still determining a root cause and are working to resolve this issue as quickly as possible.

We understand the disruption this may be causing in the classroom and we greatly appreciate your patience while we continue to work towards a resolution.
Posted Jan 04, 2024 - 11:27 EST
This incident affected: mCLASS Assessment.