Phone Support Issue
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Jun 14, 2023 - 22:02 EDT
Investigating
The third party provider we utilize for phone support is currently experiencing an outage which is affecting our Support team. If you are experiencing issues connecting with one of our Support agents over the phone, please login to your account and open a chat with us or shoot us an email at help@amplify.com.

We are currently monitoring the situation with our third party phone provider, and we do apologize for any inconvenience this may be causing.
Posted Jun 14, 2023 - 16:27 EDT
This incident affected: Customer Support.