Amplify Home Page - Intermittent Error Messages

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 11:10 EDT

Investigating

We are aware of and investigating an issue where a 504 error message is being displayed across multiple pages across amplify.com. Our Engineering team is working to identify the root cause of and implement a fix for this issue as we speak. Currently, this is not impacting product usage.

We will continue updating this page as we receive more updates.

Thank you for your patience and we apologize for any inconvenience this may be causing.
Posted Mar 10, 2026 - 10:04 EDT
This incident affected: Amplify.com.