Login and Navigation Service Disruption

Incident Report for Amplify

Update

This issue was officially resolved the evening of Sunday 1/18. Thank you for your patience!
Posted Jan 21, 2026 - 15:48 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2026 - 11:59 EST

Investigating

We are aware of and investigating an issue disrupting login services and navigation across all products right now.

Our Engineering team is working to identify the root cause of and implement a fix for this issue as we speak.


Thank you for your patience!
Posted Jan 13, 2026 - 10:44 EST

Monitoring

All services have recovered.

We are continuing to monitor.

Thank you again for your patience!
Posted Jan 12, 2026 - 15:10 EST

Update

Login services and navigational load times have recovered.

Administrator Reports pages may still be experiencing long load times right now.
Posted Jan 12, 2026 - 14:44 EST

Update

Login issues have recovered but users are still experiencing general slowness in the system. We are continuing to narrow down the root cause.
Posted Jan 12, 2026 - 14:25 EST

Investigating

We are aware of and investigating an issue disrupting login services and navigation across all products right now.

Our Engineering team is working to identify the root cause of and implement a fix for this issue as we speak.

We apologize for this inconvenience and will update this page as efforts towards resolution progress.

Thank you for your patience!
Posted Jan 12, 2026 - 14:20 EST
This incident affects: Amplify CKLA, Amplify ELA, Boost Reading, Amplify Science, Amplify Math, Desmos Classroom, mCLASS Assessment, mCLASS Intervention, and Desmos Classroom.