Phone Support Service Issue

Incident Report for Amplify

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 17:08 EDT

Monitoring

Our phone service provider recently updated the status of these issues to Resolved. We are going to leave our status in Monitoring for the time being. Please feel free to continue connecting with our Support Team via phone now!

Thank you so much!
Posted Sep 04, 2025 - 15:46 EDT

Identified

Our phone provider is currently reporting degraded performance with several of their applications. As a result, our phone support may experience intermittent connectivity issues.

We are monitoring the status page of our phone provider for updates and will relay those updates here.

In the meantime, you can contact with us via Chat by logging into your account or by Web Form (service.amplify.com/s/support).

We appreciate your patience and hope this issue is resolved soon!
Posted Sep 04, 2025 - 14:45 EDT
This incident affected: Customer Support.