Administrator Reports Access

Incident Report for Amplify

Resolved

A fix for this access issue has been released and confirmed on Production. Teachers with reporting access are now able to access Administrator Reports.

Thank you for your patience!
Posted Oct 17, 2025 - 23:09 EDT

Investigating

Due to a recent update, some users who previously had access to Administrator Reports for mCLASS are now seeing an Uh Oh! error message.

Our Product team is actively working to resolve this issue and we expect resolution by EOD.
Posted Oct 17, 2025 - 14:05 EDT
This incident affected: mCLASS Assessment and mCLASS Intervention.