Some Services Unavailable Due to Upstream Provider Issues
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 20:17 EDT
Monitoring
Per AWS: "We are now observing sustained recovery of error rates, and recovery of other affected AWS services. We are continuing to monitor closely as we work towards full recovery across all services."

Amplify is observing the same recovery in our products, and are also continuing to monitor.
Posted Jun 13, 2023 - 16:53 EDT
Update
We are seeing continued improvement in error rates, and are continuing to work towards full recovery.
Posted Jun 13, 2023 - 16:43 EDT
Identified
We have been able to redirect some of our services and are seeing some relief as a result of these efforts. There is still an outage underway at AWS, but this would only be affecting one region of users, and those are the users we are working on redirecting to an unaffected AWS server.
Posted Jun 13, 2023 - 15:39 EDT
Investigating
One of our upstream providers (AWS - https://health.aws.amazon.com/health/status) is experiencing an outage at the moment. This is affecting our Support teams' ability to access some internal databases and may be causing some issues for users to navigate both mCLASS and Curriculum platforms after login.

We are monitoring the situation with our upstream provider and will provide updates in tandem with theirs.
Posted Jun 13, 2023 - 15:29 EDT
This incident affected: Amplify CKLA, Amplify ELA, Amplify Reading, Amplify Science, Amplify Math, Desmos Classroom, mCLASS Assessment, mCLASS Intervention, and Customer Support.