mCLASS Affected by AWS Service Issues
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Sep 19, 2023 - 07:58 EDT
Investigating
We have been seeing an uptick in reports of errors on mCLASS Home and on the Teacher-Led assessment site. We have identified the root cause of this issue as stemming from service issues with one of our upstream providers, AWS. We are continuing to monitor their situation here: https://health.aws.amazon.com/health/status. 



While we are aware of the impact to mCLASS, other products may be impacted by the services issues with AWS, as well.



As always, we greatly appreciate your patience and hope this issue has not caused too much of a disruption to your day.
Posted Sep 18, 2023 - 17:21 EDT
This incident affected: mCLASS Assessment.