Reported issue with page load times for several applications.
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Jan 25, 2021 - 19:46 EST
Monitoring
We have implemented a solution and we will continue to closely monitor the situation.
Posted Jan 25, 2021 - 12:29 EST
Update
We are starting to see improvements in performance with Amplify programs, however we are still closely monitoring the situation and will continue to update this page. We are very sorry for the disruption.
Posted Jan 25, 2021 - 11:43 EST
Update
We are currently investigating an issue where you might not be able to access your Amplify program. Our team is aware of the issue and working to resolve it at this time. We’re sorry for the interruption this may be causing you and your students.
Posted Jan 25, 2021 - 11:07 EST
Identified
We are currently investigating an issue where Amplify users are experiencing issues with page load times. Our team is aware of the issue and is working to resolve it at this time. We apologize for the disruption this may be causing.
Posted Jan 25, 2021 - 10:32 EST
This incident affected: Amplify ELA, Amplify Reading, and Amplify Science.