ELA and Science Unit eReader Disruption
Incident Report for Amplify
Resolved
This incident is now resolved.
Posted Jul 28, 2021 - 18:24 EDT
Investigating
We are currently investigating an issue where users of ELA and Science products are unable to access the text excerpts in the unit via the eReader. Our team is aware of the issue and is working to resolve it at this time. We apologize for the disruption this may be causing.
Posted Jul 28, 2021 - 18:09 EDT
This incident affected: Amplify ELA and Amplify Science.