DIBELS Data System disruption
Incident Report for Amplify
Resolved
This incident has been resolved.
Posted Sep 21, 2022 - 13:07 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2022 - 11:40 EDT
Update
We are continuing to investigate this issue.
Posted Sep 21, 2022 - 11:37 EDT
Investigating
We are currently investigating an issue where users of DIBELS Data System (DDS) may receive an error message or delayed loading times when accessing their program. Our team is aware of the issue and is working to resolve it at this time. We apologize for the disruption this may be causing.
Posted Sep 21, 2022 - 11:37 EDT
This incident affected: mCLASS Assessment.